pat a1001

1001 A+B Format (20 分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10
​6
​​ ≤a,b≤10
​6
​​ . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9
Sample Output:

-999,991

代码
#include<stdio.h>
int main()
{
int a,b;
int sum;
int t=0;
int i=0;
int c[7];
scanf("%d%d",&a,&b);
sum=a+b;
if(sum<0)
{
printf("-");
sum=-sum;
}
if(sum0)
printf(“0”);
while(sum)
{
c[i]=sum%10;
sum=sum/10;
i++;
}
if(i%3!=0)
{
for(int j=i-1;j>i-1-i%3;j–)
printf("%d",c[j]);
if(i>3)
printf(",");
for(int k=i-1-i%3;k>=0;k–)
{
printf("%d",c[k]);
t++;
if(t%3
0&&k!=0)
{
printf(",");
t=0;
}
}
}
else
for(int j=i-1;j>=0;j–)
{
printf("%d",c[j]);
t++;
if(t%3==0&&j!=0)
{
printf(",");

   }
}

}

猜你喜欢

转载自blog.csdn.net/qq_41474792/article/details/86636927