1106 Lowest Price in Supply Chain (25 分)(PAT 甲级,树的BFS,DFS)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10^5​ ), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:
Ki​​ ID[1] ID[2] … ID[K​i]
where in the i-th line, K​i is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K​j being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10^​10​​ .

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2

题目大意

供应链由零销商、经销商、供应商组成,从供应商开始,供应链上的每个人在购买货物的时候需要支付比原价格多r%的费用,供应链上不存在环,本题要求求出顾客为购买货物支付的最少费用,并且求出最低价格的供应链存在的条数

分析

本题涉及树的遍历,可以采用深度优先遍历或者广度优先遍历,本题采用深度优先遍历,在遍历的过程中记录节点的层数,当遇到叶子节点时,判断当前的叶子节点是否符合题目要求,若层数level小于当前记录的层数minlevel,则更新milevel并且设置count为1(当前符合路径的数目),若层数level等于当前记录的层数milevel,则说明有找到了一条符合题意的路径,则自加1

 #include <iostream>
 #include <cmath>
 #include <vector>
 using namespace std;
 vector<vector<int> > v;
 vector<int> level;
 int count=1,minlevel=100010;
 void dfs(int u,int l){
 	if(v[u].size()==0){
 		level[u]=l;
 		if(minlevel>l){
 			count=1;
 			minlevel=l;
		 }else if(minlevel==l){
		 	count++;
		 }
	 }else{
	 	for(int w=0;w<v[u].size();w++){
	 		dfs(v[u][w],l+1);
		 }
	 }	
 }
 int main(){
 	int n;
 	double price,rate;
 	cin>>n>>price>>rate;
 	v.resize(n),level.resize(n);
 	for(int i=0;i<n;i++){
 		int cnt;
 		cin>>cnt;
 		v[i].resize(cnt);
 		for(int j=0;j<cnt;j++){
 			cin>>v[i][j];
		 }
	 }
	 dfs(0,0);
	 double ans=price*pow(1+rate/100.0,minlevel); 
	 printf("%.4lf %d",ans,count);
 	return 0;
 }

猜你喜欢

转载自blog.csdn.net/whutshiliu/article/details/82913218