1130 Infix Expression (25 分)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPG infix2.JPG
Figure 1 Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
#include<set>
#include<queue>
using namespace std;
struct Node {
	string str;
	int left = -1, right = -1;
}node[30];
int n, rt;
int fa[30] = { 0 };
void postorder(int root) {
	if (node[root].left != -1)
		postorder(node[root].left);
	if (node[root].right != -1)
		postorder(node[root].right);
	if (root != rt) {
		if (node[root].left != -1 && node[root].right != -1) node[root].str = "(" + node[node[root].left].str + node[root].str + node[node[root].right].str + ")";
		else if (node[root].left == -1 && node[root].right != -1) node[root].str = "(" + node[root].str + node[node[root].right].str + ")";
		else if (node[root].left != -1 && node[root].right == -1) node[root].str = "(" + node[node[root].left].str + node[root].str + ")";
	}
	else cout << node[node[root].left].str << node[root].str << node[node[root].right].str;
}
int main() {
	cin >> n;
	for (int i = 1; i <= n; i++) {
		cin >> node[i].str >> node[i].left >> node[i].right;
		fa[node[i].left] = fa[node[i].right] = i;
	}
	for (int i = 1; i <= n; i++) {
		if (fa[i] == 0) rt = i;
	}
	postorder(rt);
	cout << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41937767/article/details/86599381