1130 Infix Expression(25 分)(C++)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPG infix2.JPG
Figure 1 Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

作为树的中序遍历的考察,这道题还是有点意思的。

首先先明确一下,不可能出现只有左孩子的节点。其次,不难看出这只是一个已知树的形状的中序遍历,但是关键问题在于"()"怎么加,前面确定一个节点不可能只有左孩子,那么观察不难看出,但凡有孩子节点(换言之但凡有右孩子节点的节点),且不是根节点,在其下所有的节点遍历完成之后需要加上“()”。

#include <iostream>
#include <string>
#include <vector>
using namespace std;
int r=1,n;
bool root[30];
std::vector<node> v;
typedef struct{
    string s;
    int l,s;
}node;
string dfs(int index){
    if(index=="-1")
        return "";
    if(v[index]!=-1){
        v[index].s=dfs(v[index].l)+v[index].s+dfs(v[index].r);
        if(index!=root)
            v[index].s='('+v[index].s+')';
    }
    return v[index].s;
}
int main(){
    scanf("%d",&n);
    v.resize(n+1);
    for(int i=1;i<=n;i++){
        cin>>v[i].s;
        scanf("%d %d",&v[i].l;&v[i].r);
        if(v[i].l!=-1)
            root[v[i].l]=true;
        if(v[i].r!=-1)
            root[v[i].r]=true;
    }
    while(root[r]==true)
        r++;
    cout<<dfs(r);
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82526227