HDU-2062 Bone Collector(01背包)

版权声明:商业转载请联系作者获得授权,非商业转载请注明出处。 https://blog.csdn.net/weixin_43939327/article/details/85092097

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 89264 Accepted Submission(s): 36760

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

Author
Teddy

Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest

Recommend
lcy

题目分析:

01背包经典例题。没啥说的,上链接: http://www.wutianqi.com/?p=539

代码实现:

#include<bits/stdc++.h>
using namespace std;
int jia[1005];
int v[1005];
int p[1005];

int main()
{
    int T,a,b;
    scanf("%d",&T);
    while(T--)
    {
        memset(v,0,sizeof(v));
        memset(jia,0,sizeof(jia));
        memset(p,0,sizeof(p));
        scanf("%d%d",&a,&b);
        for(int i=1;i<=a;i++) scanf("%d",&jia[i]);
        for(int i=1;i<=a;i++) scanf("%d",&v[i]);
        for(int i=1;i<=a;i++)
        {
            for(int j=b;j>=v[i];j--)
            {
                p[j]=p[j]>p[j-v[i]]+jia[i]?p[j]:p[j-v[i]]+jia[i];
            }
        }
        printf("%d\n",p[b]);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_43939327/article/details/85092097