HDU-2601 Bone Collector( 01背包 )

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

分析:简单的背包问题,可选择二维或一维动态数组,进行求解。谨慎使用cin,cout.

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX = 2010;
int dp[MAX][MAX];
int o[MAX], w[MAX];
int main()
{
	int T, N, V, i, j;
	cin >> T;
	while (T--)
	{
		scanf("%d%d", &N, &V);
		memset(dp, 0, sizeof(dp));
		for (i = 0; i < N; i++)
		{
			scanf("%d", &o[i]);
		}
		for (i = 0; i < N; i++)
		{
			scanf("%d", &w[i]);
		}
		for (i = 0; i < N; i++)
		{
			for (j = 0; j <= V; j++)
			{
				if (j < w[i])
				{
					dp[i + 1][j] = dp[i][j];
				}
				else
				{
					dp[i + 1][j] = max(dp[i][j], dp[i][j - w[i]] + o[i]);
				}
			}
		}
		cout << dp[N][V] << endl;
	}
    return 0;
	
}

猜你喜欢

转载自blog.csdn.net/fighting_yifeng/article/details/81284348