hdu-2000-ASCII码排序

输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input
qwe
asd
zxc
Sample Output
e q w
a d s
c x z

链接:https://vjudge.net/problem/hdu-2000

我的思路:用while不解释了,字符直接通过ASCII码比较大小按顺序输出就完事。

代码如下:

#include <iostream>
using namespace std;

int main()
{
	char a[3], c;
	while (cin >> a[0] >> a[1] >> a[2])
	{
		if (a[1] > a[2])
		{
			c = a[1];
			a[1] = a[2];
			a[2] = c;
		}
		if (a[0] > a[1])
		{
			c = a[0];
			a[0] = a[1];
			a[1] = c;
		}
		if (a[1] > a[2])
		{
			c = a[1];
			a[1] = a[2];
			a[2] = c;
		}
		cout << a[0] <<" "<< a[1] <<" "<< a[2] << endl;

	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43999137/article/details/84866729
今日推荐