hdu_problem_2000_ASCII码排序

/*
*
*
*Problem Description
*输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
*
*
*Input
*输入数据有多组,每组占一行,有三个字符组成,之间无空格。
*
*
*Output
*对于每组输入数据,输出一行,字符中间用一个空格分开。
*
*
*Sample Input
*qwe
*asd
*zxc
*
*
*Sample Output
*e q w
*a d s
*c x z
*
*
*Author
*lcy
*
*
*Source
*C语言程序设计练习(一)
*
*
*Recommend
*JGShining
*
*/
#include<iostream>
using namespace std;
void sort(char *a, char *b, char *c) {
 if (*a > *b) swap(*a, *b);
 if (*a > *c) swap(*a, *c);
 if (*b > *c) swap(*b, *c);
}
int main() {
 char a,b,c;
 while (cin >> a >> b >> c) {
  sort(&a, &b, &c);
  cout << a << " " << b << " " << c << endl;
 }
 system("pause");
 return 0;
}

猜你喜欢

转载自blog.csdn.net/CoderMaximum/article/details/86133927
今日推荐