【HDU - 5500】 Reorder the Books (思维)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/86572447

题干:

dxy has a collection of a series of books called "The Stories of SDOI",There are n(n≤19)n(n≤19) books in this series.Every book has a number from 11 to nn. 

dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them. 

One day Evensgn visited dxy's home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about "Little E&Little Q". While losing himself in the story,he disrupted the order of the books. 

Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top. 

Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book "The Stories of SDOI 9: The Story of Little E" as a gift. 

Input

There are several testcases. 

There is an positive integer T(T≤30)T(T≤30) in the first line standing for the number of testcases. 

For each testcase, there is an positive integer nn in the first line standing for the number of books in this series. 

Followed nn positive integers separated by space standing for the order of the disordered books,the ithith integer stands for the ithith book's number(from top to bottom). 


Hint: 
For the first testcase:Moving in the order of book3,book2,book1book3,book2,book1 ,(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4)(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4),and this is the best way to reorder the books. 
For the second testcase:It's already ordered so there is no operation needed.

Output

For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.

Sample Input

2
4
4 1 2 3
5
1 2 3 4 5

Sample Output

3
0

题目大意:

   有n本带编号的书,现在给你打乱了顺序,定义一次操作可以任选一本书并且放到最顶部。问你最少需要多少次操作可以将这一摞书调整为有序(编号从小到大)?

解题报告:

     直接模拟就行了。。先找出来需要移动多少本书,假设是x本,那么肯定可以通过x次操作还原回来。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
#define fi first
#define se second
using namespace std;
const int MAX = 2e5 + 5;
int ji,ou,all,n;
int a[MAX];
int main()
{
	int t;
	cin>>t;
	while(t--) {
		cin>>n;
		for(int i = 1; i<=n; i++) scanf("%d",a+i);
		int now = n,ans=0;
		for(int i = n; i>=1; i--) {
			if(now == a[i]) now--;
			else ans++;
		}
		printf("%d\n",ans);
	} 
	

	return 0 ;
 }

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/86572447