dfs之油田问题

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1241

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46962    Accepted Submission(s): 27038


 

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

Sample Input

1 1 
* 
3 5 
*@*@* 
**@** 
*@*@* 
1 8 
@@****@* 
5 5 
****@ 
*@@*@ 
*@**@ 
@@@*@ 
@@**@ 
0 0

Sample Output

0 
1 
2 
2

题目大意:‘@’就是油,它的周围(上下左右斜着)如果也有‘@’出现,那么就是合成一块大油田,要求总共有多少块大油田。

思路:一个一个搜索,dfs就行,模板题。

ac代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char map[110][110];
int vis[110][110];
int m,n;

void dfs(int x,int y,int sum){
	if(x<0||y<0||x>=m||y>=n){
		return;
	}
	if(map[x][y]!='@')return;
	map[x][y]='*';
	for(int dx=-1;dx<=1;dx++){
		for(int dy=-1;dy<=1;dy++){
			if(dx!=0||dy!=0)
			dfs(x+dx,y+dy,sum);
		}
	}
}
int main(){
	while(scanf("%d%d",&m,&n)&&m&&n){
		for(int i = 0; i < m; i ++)
        {
            getchar();
            for(int j = 0; j < n; j ++)
            {
                scanf("%c",&map[i][j]);
            }
        }

		memset(vis,0,sizeof(vis));
		int sum=0;
		for(int i=0;i<m;i++){
			for(int j=0;j<n;j++){
				if(map[i][j]=='@')
				dfs(i,j,++sum);
			}
		}
		cout<<sum<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41515833/article/details/86562850