HDU-1241-Oil Deposits 油田问题(DFS)

Oil Deposits

原题链接:
http://acm.hdu.edu.cn/showproblem.php?pid=1241

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0

Sample Output

0
1
2
2

代码:

#include<stdio.h>
#include<string.h>
char map[110][110];//储存数据
int n,m;
//八个方位
int vis[8][2]={{-1,-1},{-1,0},{-1,1},{0,1},{0,-1},{1,1},{1,0},{1,-1}};
void dfs(int x,int y)   //深度优先搜索
{
    map[x][y]='*';//搜索过的@都变为*
    for(int i=0;i<8;i++)
    {
        //下一个点的坐标
        int dx=x+vis[i][0];
        int dy=y+vis[i][1];
        if(dx<0||dx>=n||dy<0||dy>=m)//判断是否越界
        {
            continue;
        }
        if(map[dx][dy]=='@')
        {
            dfs(dx,dy);//开始尝试下一个点
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        //memset(map,0,sizeof(map));
        //清空数组,其实没必要,定义的map是全局变量
        if(m==0)
            break;
        for(i=0;i<n;i++)
        {
            scanf("%s",map[i]);
        }
        int sum=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(map[i][j]=='@')//查找
                {
                    sum++;
                    dfs(i,j);
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
发布了33 篇原创文章 · 获赞 35 · 访问量 1286

猜你喜欢

转载自blog.csdn.net/qq_45856289/article/details/103736275