PAT_B_1052 卖个萌 (20 分)【最后两个测试点】

最后两个测试点错误的原因:注意下界!注意下界!注意下界!

萌萌哒表情符号通常由“手”、“眼”、“口”三个主要部分组成。简单起见,我们假设一个表情符号是按下列格式输出的:

[左手]([左眼][口][右眼])[右手]

现给出可选用的符号集合,请你按用户的要求输出表情。

输入格式:

输入首先在前三行顺序对应给出手、眼、口的可选符号集。每个符号括在一对方括号 []内。题目保证每个集合都至少有一个符号,并不超过 10 个符号;每个符号包含 1 到 4 个非空字符。

之后一行给出一个正整数 K,为用户请求的个数。随后 K 行,每行给出一个用户的符号选择,顺序为左手、左眼、口、右眼、右手——这里只给出符号在相应集合中的序号(从 1 开始),数字间以空格分隔。

输出格式:

对每个用户请求,在一行中输出生成的表情。若用户选择的序号不存在,则输出 Are you kidding me? @\/@

输入样例:

[╮][╭][o][~\][/~]  [<][>]
 [╯][╰][^][-][=][>][<][@][⊙]
[Д][▽][_][ε][^]  ...
4
1 1 2 2 2
6 8 1 5 5
3 3 4 3 3
2 10 3 9 3

输出样例:

╮(╯▽╰)╭
<(@Д=)/~
o(^ε^)o
Are you kidding me? @\/@
#include <iostream>
#include <string>
using namespace std;

int main()
{
    char hand[10][5];
    char eye[10][5];
    char mouth[10][5];
    string str;
    int flag=0,handi=0,eyei=0,mouthi=0;
    int handcount=0,eyecount=0,mouthcount=0;
    /////手
    getline(cin,str);
    int len=str.size();
    for(int i=0;i<len;i++)
    {
        if(str[i]=='[')
        {
            flag=1;
            handi=0;
            continue;
        }
        if(str[i]==']')
        {
            flag=0;
            hand[handcount][handi]='\0';
            handcount++;
            continue;
        }
        if(flag)
            hand[handcount][handi++]=str[i];
    }
    /////眼
    getline(cin,str);
    len=str.size();
    flag=0;
    for(int i=0;i<len;i++)
    {
        if(str[i]=='[')
        {
            flag=1;
            eyei=0;
            continue;
        }
        if(str[i]==']')
        {
            flag=0;
            eye[eyecount][eyei]='\0';
            eyecount++;
            continue;
        }
        if(flag)
            eye[eyecount][eyei++]=str[i];
    }
    /////口
    getline(cin,str);
    len=str.size();
    flag=0;
    for(int i=0;i<len;i++)
    {
        if(str[i]=='[')
        {
            flag=1;
            mouthi=0;
            continue;
        }
        if(str[i]==']')
        {
            flag=0;
            mouth[mouthcount][mouthi]='\0';
            mouthcount++;
            continue;
        }
        if(flag)
            mouth[mouthcount][mouthi++]=str[i];
    }

    int N;
    cin>>N;
    int lHand,lEye,Mou,rEye,rHand;
    string output="";
    string temp="";
    while(N--)
    {
        cin>>lHand>>lEye>>Mou>>rEye>>rHand;
        temp="";
        if(lHand<=handcount&&rHand<=handcount&&lEye<=eyecount&&rEye<=eyecount&&Mou<=mouthcount
           &&lHand>0&&rHand>0&&lEye>0&&rEye>0&&Mou>0)   //下界,最后两个测试点
        {
            temp+=hand[lHand-1];
            temp+="(";
            temp+=eye[lEye-1];
            temp+=mouth[Mou-1];
            temp+=eye[rEye-1];
            temp+=")";
            temp+=hand[rHand-1];
        }
        else
        {
            temp="Are you kidding me? @\\/@";
        }
        output+=temp+'\n';
    }
    cout<<output;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/id33749110/article/details/86522876