PAT乙级-1052 卖个萌 (20分)

点击链接PAT乙级-AC全解汇总

题目:
萌萌哒表情符号通常由“手”、“眼”、“口”三个主要部分组成。简单起见,我们假设一个表情符号是按下列格式输出的:

[左手]([左眼][][右眼])[右手]

现给出可选用的符号集合,请你按用户的要求输出表情。

输入格式:
输入首先在前三行顺序对应给出手、眼、口的可选符号集。每个符号括在一对方括号 []内。题目保证每个集合都至少有一个符号,并不超过 10 个符号;每个符号包含 1 到 4 个非空字符。

之后一行给出一个正整数 K,为用户请求的个数。随后 K 行,每行给出一个用户的符号选择,顺序为左手、左眼、口、右眼、右手——这里只给出符号在相应集合中的序号(从 1 开始),数字间以空格分隔。

输出格式:
对每个用户请求,在一行中输出生成的表情。若用户选择的序号不存在,则输出

Are you kidding me? @/@。

输入样例:

[][][o][~\][/~]  [<][>]
 [][][^][-][=][>][<][@][]
[Д][][_][ε][^]  ...
4
1 1 2 2 2
6 8 1 5 5
3 3 4 3 3
2 10 3 9 3

输出样例:

(╯▽╰)<(=)/~
o(^ε^)o
Are you kidding me? @\/@

我的代码:

#include<iostream>
#include<cstdio>
#include<vector>
#include<string>
#include<set>
#include<map>
#include<algorithm>
#include<cmath>
#include<ctime>
#include<cstring>
#include<sstream>
using namespace std;
//有的时候题目是一起做的,所以会有不需要的头文件

int main()
{
    string hand[11],eye[11],mouth[11];
    string kidding="Are you kidding me? @\\/@";
    int num_hand=0,num_eye=0,num_mouth=0;

    string temp;
    //hand
    getline(cin,temp);
    while(temp.find('[')!=-1)
    {
        int pos1=temp.find('[');
        int pos2=temp.find(']');
        hand[num_hand++].append(temp,pos1+1,pos2-pos1-1);
        temp.erase(pos1,pos2-pos1+1);
    }
    //eye
    getline(cin,temp);
    while(temp.find('[')!=-1)
    {
        int pos1=temp.find('[');
        int pos2=temp.find(']');
        eye[num_eye++].append(temp,pos1+1,pos2-pos1-1);
        temp.erase(pos1,pos2-pos1+1);
    }
    //mouth
    getline(cin,temp);
    while(temp.find('[')!=-1)
    {
        int pos1=temp.find('[');
        int pos2=temp.find(']');
        mouth[num_mouth++].append(temp,pos1+1,pos2-pos1-1);
        temp.erase(pos1,pos2-pos1+1);
    }

    int N;
    cin>>N;
    for(int i=0;i<N;i++)
    {
        int a=11,b=11,c=11,d=11,e=11;
        scanf("%d %d %d %d %d",&a,&b,&c,&d,&e);
        if(a>num_hand||b>num_eye||c>num_mouth||d>num_eye||e>num_hand||
           a<1||b<1||c<1||d<1||e<1)
            cout<<kidding<<endl;
        else
            cout<<hand[a-1]<<"("<<eye[b-1]<<mouth[c-1]<<eye[d-1]<<")"<<hand[e-1]<<endl;
    }

    return 0;
}

注意输入abcde<1的情况

发布了82 篇原创文章 · 获赞 1 · 访问量 1683

猜你喜欢

转载自blog.csdn.net/qq_34451909/article/details/104836384
今日推荐