PAT Advanced1024 Palindromic Number(高精度运算)

版权声明:个人学习笔记记录 https://blog.csdn.net/Ratina/article/details/86363753

链接:PAT Advanced1024

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3


题意: 定义一种操作——让一个整数加上其反转后得到的整数。
给出一个正整数N和操作次数K限制,若在操作次数限制K内可以得到回文数,则输出该回文数和操作次数,反之输出最后一次得到的数和操作次数。


分析: 因为K≤100,那么最后得到的数是可能超过long long类型的,那么就要用高精度(大整数)处理了。具体看代码。


#include<iostream>
#include<string>
#include<cstring>
using namespace std;
struct bign
{
	int d[1000];
	int len;
	bign()
	{
		memset(d,0,sizeof(d));
		len=0;
	}
};
bign change(string s)
{
	bign a;
	for(int i=s.length()-1;i>=0;i--)
		a.d[a.len++]=s[i]-'0';
	return a;
}
void print(bign n)
{
	for(int i=n.len-1;i>=0;i--)
		cout<<n.d[i];
}
bign reverse(bign n)      //得到 n反转后的数
{
	bign a;
	for(int i=n.len-1;i>=0;i--)
		a.d[a.len++]=n.d[i];
	return a;
}
bign add(bign x,bign y)   //高精度加法
{
	bign a;
	int i,t,carry=0;      //carry为进位,记得初始化为 0
	for(i=0;i<x.len||i<y.len;i++)
	{
		t=x.d[i]+y.d[i]+carry;
		a.d[a.len++]=t%10;
		carry=t/10;
	}
	if(carry)             //若carry不为 0
		a.d[a.len++]=carry;
	return a;
}
bool ispnum(bign n)       //判断是否为回文数
{
	bign t=reverse(n);
	for(int i=0;i<t.len;i++)
	{
		if(t.d[i]!=n.d[i])
			return false;
	}
	return true;
} 
int main()
{   
	string t;
	bign N;
	int cnt=0,K;
	cin>>t>>K;
	N=change(t);
	while(!ispnum(N)&&cnt<K)
	{
		N=add(N,reverse(N));   //将 N和 N的反转数相加
		cnt++;
	}
	print(N);
	cout<<endl<<cnt;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ratina/article/details/86363753
今日推荐