POJ-3245 Corn Fields(状压dp入门题)

题目链接:http://poj.org/problem?id=3254

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows: 

1 2 3
  4  


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

状态压缩入门https://blog.csdn.net/u013377068/article/details/81054112

题解https://blog.csdn.net/LYHVOYAGE/article/details/24691009

题意:农夫FJ有一块n行m列的矩形土地, 有的土地是肥沃的,可以在这些土地上放牛(用1表示),有的土地不能放牛(用0表示),而且相邻的可以放牛的格子不能同时有牛,问FJ一共有多少种放牛的方案(一头牛都不放也是一种方案)。

分析:以样例为例,我们可以一行一行的考虑。假如对于每一行,用1表示放牛,0表示不放牛,

第一行的状态为:000    001    010    011(舍弃) 100    101    110(舍弃)111(舍弃)

符合题意的状态只有5个,所以第一行有5种方案。

第二行的状态为:000   010

但是第二行中的010和第一行中的010冲突,所以如果第二行状态为010时,共有4种方案;状态为000时,有5种方案,所以一共有4+5=9种方案。

分析完我们会发现,对于每一行,都可以一个01串来表示这一行的状态,而这个状态可以用一个十进制整数来代替,也就是说,把这个状态压缩成了一个十进制整数,所以称为是状态压缩。

本题中,dp[i][j] 就表示第i行状态为j时的方案数。

状态压缩dp中最常见的就是位运算,因为位运算可以很方便的判断当前状态是否合法。例如本题中判断第i行是不是有两块相邻的土地同时都有牛,假设当前状态为X,那么只需要判断X&(X>>1)或者X&(X<<1)的结果是不是0,如果是0,说明没有相邻的,否则就说明有相邻的。

#include<cstdio>
#include<cstring>
using namespace std;
const int N=13;
const int mod=1e8;
int dp[N][1<<N];
int map[N];//压缩地图
bool Rjudge(int x) {  //判断本行是否有冲突
	return !(x&(x>>1));
}
bool Cjudge(int a,int b) { //判断和上一行是否冲突
	return !(a&b);
}
int main() {
	int n,m,x;
	while(~scanf("%d%d",&n,&m)) {
		memset(dp,0,sizeof(dp));
		memset(map,0,sizeof(map));
		for(int i=0; i<n; i++) {
			for(int j=0; j<m; j++) {
				scanf("%d",&x);
				if(x) map[i]=map[i]|(1<<j);
			}
		}
		for(int i=0; i<(1<<m); i++) {         //求出第一行的合法状态 
			if((map[0]|i)==map[0]&&Rjudge(i))
				dp[0][i]=1;
		}
		for(int i=1; i<n; i++) {
			for(int j=0; j<(1<<m); j++) { //枚举本行状态
				if((map[i]|j)==map[i]&&Rjudge(j)) {
					for(int k=0; k<(1<<m); k++) { //枚举上一行状态
						if(Cjudge(j,k))//判断两行状态是否冲突
							dp[i][j]=(dp[i][j]+dp[i-1][k])%mod;
					}
				}
			}
		}
		int ans=0;
		for(int i=0; i<(1<<m); i++)
			ans=(ans+dp[n-1][i])%mod;
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/86547980