【状压dp】 POJ - 3254 Corn Fields

Corn Fields  POJ - 3254 

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows: 

1 2 3
  4  
There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int mod=1e9;
int dp[13][1<<13],a[13][13];

int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        for(int j=0;j<m;j++)
        {
            cin>>a[i][j];
        }
    }
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        dp[i][0]=ans;
        for(int S=1;S<(1<<m);S++)
        {
            int flag=0;
            for(int j=0;j<m;j++)
            {
                if(j>0&&(S>>j&1)&&(S>>(j-1)&1)) flag=1;  //不能放砖块的地方放了,continue
                if(a[i][j]==0&&(S>>j&1)) flag=1;         //相邻都放了,continue
            }
            if(flag==1) continue;
            dp[i][S]=ans+1;
            for(int s=1;s<(1<<m);s++)  //实际上最多也就300+的情况
            {
                if(S&s) dp[i][S]=(dp[i][S]-dp[i-1][s]+mod)%mod; //要是上下相邻放了,也不行,因为有mod所以怕出负数,+mod%mod
            }
        }
        ans=0;
        for(int S=0;S<(1<<m);S++)
        {
            ans=(ans+dp[i][S])%mod;
        }
    }
    printf("%d\n",(ans+1)%mod); //加1是因为可能出现全空的情况
    return 0;
}
用二维滚动数组,节省空间
int dp[2][1<<13],a[13][13];
int *cnt=dp[0], *next=dp[1];
注意一轮结束后cnt=next,next要清零

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int mod=1e9;
int dp[2][1<<13],a[13][13];
int *cnt=dp[0], *next=dp[1];

int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        for(int j=0;j<m;j++)
        {
            cin>>a[i][j];
        }
    }
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        next[0]=ans;
        for(int S=1;S<(1<<m);S++)
        {
            int flag=0;
            for(int j=0;j<m;j++)
            {
                if(j>0&&(S>>j&1)&&(S>>(j-1)&1)) flag=1;
                if(a[i][j]==0&&(S>>j&1)) flag=1;
            }
            if(flag==1) continue;
            next[S]=ans+1;
            for(int s=1;s<(1<<m);s++)
            {
                if(S&s) next[S]=(next[S]-cnt[s]+mod)%mod;
            }
        }
        ans=0;
        for(int S=0;S<(1<<m);S++)
        {
            ans=(ans+next[S])%mod;
            cnt[S]=next[S];
            next[S]=0;
        }
    }
    printf("%d\n",(ans+1)%mod);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81407808
今日推荐