PAT (Advanced Level) Practice A1084 Broken Keyboard (20 分)(C++)(甲级)(散列)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/86476230

1084 Broken Keyboard (20 分)
On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es
Sample Output:

7TI

//B1029 旧键盘 (20 分)英文版
//https://blog.csdn.net/m0_37454852/article/details/86476172

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

int Key[50] = {0};

int mapping(char ch)//查询该字符的散列位置
{
    if(ch>='a' && ch<='z') return ch-'a';//A~Z在0~25
    else if(ch>='A' && ch<='Z') return ch-'A';
    else if(ch>='0' && ch<='9') return ch-'0' + 26;//0~9在26~35
    return 36;//_在36
}

int main()
{
    char str1[100] = {0}, str2[100] = {0};
    scanf("%s", str1);
    int len1 = strlen(str1);
    int x=0;
    for(int i=0; i<len1; i++)
    {
        x = mapping(str1[i]);
        if(!Key[x]) Key[x] = 1;//在第一个字符中出现,把标志置为1
    }
    scanf("%s", str2);
    int len2 = strlen(str2);
    for(int i=0; i<len2; i++)
    {
        x = mapping(str2[i]);//在第二串字符中出现把标志清零
        Key[x] = 0;
    }
    for(int i=0; i<len1; i++)//再次扫描第一个字符串,若标志为1,说明该按键坏掉了
    {
        x = mapping(str1[i]);
        if(Key[x])
        {
            if(x<26) printf("%c", 'A'+x);
            else if(x<36) printf("%c", '0'+x-26);
            else printf("_");
            Key[x] = 0;//之后记得清零,否则可能会多次输出
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86476230
今日推荐