A+B问题 HDU-2101

A+B问题 HDU-2101

时限:1000 ms 内存限制:32768 kB
OS:窗 来源:HDU 2007-6编程比赛

Problem Description:This problem is also a A + B problem,but it has a little difference,you should determine does (a+b) could be divided with 86.For example ,if (A+B)=98,you should output no for result.

Input:Each line will contain two integers A and B. Process to end of file.

Output:For each case, if(A+B)%86=0,output yes in one line,else output no in one line.

Sample Input:
1 1
8600 8600

Sample Output:
no
yes

问题链接:A+B问题 HDU-2101
问题描述:给出多组数据(A和B),问A+B是否能整除86,若能,输出“yes”,反之输出“no”(不包括双引号).
问题分析:简单的运算和判断语句的使用,有两个点要注意:(1)有多组数据;(2)判断两数是否相等时,应使用逻辑运算符“==“,而不是赋值运算符"="。
AC代码如下:

#include <iostream>
using namespace std;
int main()
{
	long A, B;
	while (cin >> A >> B)
	{
		if ((A + B) % 86 == 0)
			cout << "yes" << endl;
		else
			cout << "no" << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43894577/article/details/84842018