hdu 2689 Sort it (树状数组应用类型三) 【逆序数问题】

版权声明:限于博主能力有限,不排除出现错误的地方,希望大佬指出,多多 交流,共同进步。 https://blog.csdn.net/SunPeishuai/article/details/85407595

Problem Description

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.

 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

 

Output

For each case, output the minimum times need to sort it in ascending order on a single line.

 

Sample Input

 

3 1 2 3 4 4 3 2 1

 

Sample Output

 

0 6

题意:给定一组数,交换相邻的两个数,使最后的序列为升序序列,求交换次数。

PS:关于树状数组求逆序的思想我还是推荐一篇博客吧,自己也是勉强理解https://www.cnblogs.com/xiongmao-cpp/p/5043340.html

代码:

#include<cstdio>
#include<cstring>
using namespace std;
const int N=1008;
int c[N];
/*int lowbit(int x)
{
    return (x&(-x));
}*/
void add(int x,int y)
{
    for(;x<=N;x+=(x&(-x)))
    {
        c[x]+=y;
    }
}
int sum(int x)
{
    int ans=0;
    for(;x;x-=(x&(-x)))
    {
        ans+=c[x];
    }
    return ans;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
    int ans=0;
      memset(c,0,sizeof(c));
      for(int i=1;i<=n;i++)
      {
        int x;
        scanf("%d",&x);
        add(x,1);
        ans+=i-sum(x);
      }
      printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/SunPeishuai/article/details/85407595
今日推荐