PAT (Advanced Level) Practice 1031 Hello World for U (20 分)(C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/85722450

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n
​1
​​ characters, then left to right along the bottom line with n
​2
​​ characters, and finally bottom-up along the vertical line with n
​3
​​ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n​1=n​3​​ =max { k | k≤n2​​ for all 3≤n​2​​ ≤N } with n​1+n​2+n​3 −2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!
Sample Output:

h !
e d
l l
lowor


//我这里的n1比题目中的n1小了1
//即以下代码中n1 + n2 + n3 = N

#include <cstdio>
#include <cstring>
#include <cmath>

int main()
{
	char str[100] = { 0 };
	scanf("%s", str);
	int len = strlen(str);
	int n1 = len / 3;//一般情况
	if(len%3 == 0) n1 -= 1;//为了满足n1 = n3 = max { k | k≤n2 for all 3≤n≤N } 
	int n2 = len - 2 * n1;
	for (int i = 0; i < n1; i++)
	{
		printf("%c", str[i]);//输出左半边
		for (int j = 1; j < n2 - 1; j++) printf(" ");
		printf("%c\n", str[len - i - 1]);//输出右半边
	}
	for (int i = n1; i < len - n1; i++) printf("%c", str[i]);//输出最下一行
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/85722450
今日推荐