【笨方法学PAT】1032 Sharing (25 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84620606

一、题目

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and beingare stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

二、题目大意

给定两个链表,找最开始的共同节点。

三、考点

链表

四、注意

1、暴力求解,最后一个点会超时;

2、遍历第一个并标记,之后遍历第二个。

五、代码

#include<iostream>
#include<vector>
#define N 100001
using namespace std;
struct node {
	char val;
	int next;
};
vector<node> v(N);
bool visit[N] = { false };
int main() {
	//read
	int add1, add2, n;
	cin >> add1 >> add2 >> n;
	for (int i = 0; i < n; ++i) {
		node nd;
		int add;
		cin >> add >> nd.val >> nd.next;
		v[add] = nd;		
	}

	//find
	while (add1 != -1) {
		visit[add1] = true;
		add1 = v[add1].next;
	}
	bool flag = false;
	while (add2 != -1) {
		if (visit[add2] == true) {
			flag = true;
			break;
		}
		else
			add2 = v[add2].next;
	}

	//output
	if (flag == false)
		cout << -1 << endl;
	else
		printf("%05d", add2);

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84620606