hdu 1595删边加最短路

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4862    Accepted Submission(s): 1819


 

Problem Description

Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

 

Input

Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

 

Output

In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

 

Sample Input

 

5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10

 

Sample Output

 

11 13 27

 

Author

ailyanlu

 

Source

HDU 2007-Spring Programming Contest - Warm Up (1)

 

Recommend

8600   |   We have carefully selected several similar problems for you:  1599 1596 1598 1142 1217 

 卡了将近两个小时,注意只标记删边之前

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 1005
#define inf 0x3f3f3f3f
int dis[maxn][maxn];
int vis[maxn];
int step[maxn];
int d[maxn];
int flag;
int n,m;
int dij(int s)
{memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        d[i]=i==s?0:inf;

    for(int i=1;i<=n;i++)
    {
        int x,minn=inf;
        for(int y=1;y<=n;y++)
            if(!vis[y]&&minn>=d[y])
            minn=d[x=y];

            vis[x]=1;
        for(int y=1;y<=n;y++)
            if(d[y]>d[x]+dis[x][y])
            {d[y]=d[x]+dis[x][y];
if(!flag)
            step[y]=x;
    }

    }

    return d[n];
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {int i,j;
         for(i=1; i<=n; i++)
        {
            step[i]=0;
            for(j=1; j<=n; j++)
            {
                if(i!=j)
                    dis[i][j]=inf;
                else
                    dis[i][j]=0;
            }
        }
        int a,b,c;
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(dis[a][b]>c)
                dis[a][b]=dis[b][a]=c;
        }

flag=0;
        int ans=dij(1);
flag=1;
        for(i=n; i!=1; i=step[i])
        {
            int tt=dis[i][step[i]];

            dis[i][step[i]]=dis[step[i]][i]=inf;
            int ans1=dij(1);///从0开始不再记录路径
            ans=max(ans,ans1);
            dis[i][step[i]]=dis[step[i]][i]=tt;

        }
        printf("%d\n",ans);


        }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/84899977