Philosopher’s Walk ICPC 2017 Daejeon F dfs 分治

问题 F: Philosopher’s Walk

时间限制: 1 Sec  内存限制: 128 MB
提交: 70  解决: 33
[提交] [状态] [讨论版] [命题人:admin]

题目描述

In Programming Land, there are several pathways called Philosopher’s Walks for philosophers to have a rest. A Philosopher’s Walk is a pathway in a square-shaped region with plenty of woods. The woods are helpful for philosophers to think, but they planted so densely like a maze that they lost their ways in the maze of woods of a Philosopher’s Walk.

Fortunately, the structures of all Philosopher’s Walks are similar; the structure of a Philosopher’s Walk is designed and constructed according to the same rule in a 2k meter square. The rule for designing the pathway is to take a right-turn in 90 degrees after every 1-meter step when k is 1, and the bigger one for which the integer k is greater than 1 is built up using four sub-pathways with k - 1 in a fractal style. Figure F.1 shows three Philosopher’s Walks for which k is 1, 2, and 3. The Philosopher’s Walk W2 consists of four W1 structures with the lower-left and the lower-right ones are 90 degree rotated clockwise and counter-clockwise, respectively; the upper ones have the same structure with W1. The same is true for any Wk for which the integer k is greater than 1. This rule has been devised by a mathematical philosopher David Hilbert (1862 – 1943), and the resulting pathway is usually called a HILBERT CURVE named after him. He once talked about a space filling method using this kind of curve to fill up a square with 2k sides, and every Philosophers’ Walk is designed according to this method.

Tae-Cheon is in charge of the rescue of the philosophers lost in Philosopher’s Walks using a hot air balloon. Fortunately, every lost philosopher can report Tae-Cheon the number of meter steps he has taken, and Tae-Cheon knows the length of a side of the square of the Philosopher’s Walk. He has to identify the location of the lost philosopher, the (x,y) coordinates assuming that the Philosopher’s Walk is placed in the 1st quadrant of a Cartesian plain with one meter unit length. Assume that the coordinate of the lower-left corner block is (1,1). The entrance of a Philosopher’s Walk is always at (1,1) and the exit is always (n,1) where n is the length of a side. Also assume that the philosopher have walked one meter step when he is in the entrance, and that he always go forward to the exit without back steps.

For example, if the number of meter-steps taken by a lost philosopher in the Philosopher’s Walk in W2 in Figure F.1(b) is 10, your program should report (3,4).

Your mission is to write a program to help Tae-Cheon by making a program reporting the location of the lost philosopher given the number of meter-steps he has taken and the length of a side of the square of the Philosopher’s Walk. Hurry! A philosopher urgently needs your help.

输入

Your program is to read from standard input. The input consists of a single line containing two positive integers, n and m, representing the length of a side of the square of the Philosopher’s Walk and the number of meter-steps taken by the lost philosopher, respectively, where n = 2k and m ≤ 22k for an integer k satisfying 0 < k ≤ 15.

输出

Your program is to write to standard output. The single output line should contain two integers, x and y, separated by a space, where (x,y) is the location of the lost philosopher in the given Philosopher’s Walk.

样例输入

4 10

样例输出

3 4

[提交][状态]

题里给出了一个最小的模型样子,并且解释了之后的样子,利用分治的思想,递归求解

其实重点就是求各个点之间的递归关系

代码:

#include <bits/stdc++.h>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>

const int maxn = 4e4 + 10;
using namespace std;
typedef long long ll;
struct node {
    ll x, y;
} ans;

node dfs(ll n, ll m) {
    node p;
    if (n == 2) {
        if (m == 0) p.x = 1, p.y = 1;
        if (m == 1) p.x = 1, p.y = 2;
        if (m == 2) p.x = 2, p.y = 2;
        if (m == 3) p.x = 2, p.y = 1;
        return p;
    }
    ll sum = n * n / 4;
    ll cnt = m / sum, mod = m % sum;
    //cout<<"*"<<cnt<<" "<<mod<<endl;
    p = dfs(n / 2, mod);
    //cout<<p.x<<" "<<p.y;
    if (cnt == 0) {
        swap(p.x, p.y);
        return p;
    }
    if (cnt == 1) {
        p.y = p.y + n / 2;
        return p;
    }
    if (cnt == 2) {
        p.y = p.y + n / 2;
        p.x = p.x + n / 2;
        return p;
    }
    if (cnt == 3) {
        ll temp = p.x;
        p.x = n + 1 - p.y;
        p.y = n / 2 + 1 - temp;
        return p;
    }
}

int main() {
    ll n, m;
    scanf("%lld %lld", &n, &m);
    ans = dfs(n, m - 1);
    printf("%lld %lld\n", ans.x, ans.y);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/renzijing/article/details/82938843