[洛谷]P2895 [USACO08FEB]流星雨Meteor Shower (#搜索 -2.10)

版权声明:JCBP工作室 & A.pro https://blog.csdn.net/Apro1066/article/details/83869162

题目描述

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

牛去看流星雨,不料流星掉下来会砸毁上下左右中五个点。每个流星掉下的位置和时间都不同,求牛能否活命,如果能活命,最短的逃跑时间是多少?

输入输出格式

输入格式:

* Line 1: A single integer: M

* Lines 2..M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

输出格式:

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

输入输出样例

输入样例#1

4
0 0 2
2 1 2
1 1 2
0 3 5

输出样例#1

5

思路

翻译好坑啊。

题目大意:

现有一个平面直角坐标系,牛的初始位置为(0,0),且可以在 x、y 的正半轴以及第一象限内活动。在左下角为(0,0),右上角为(300,300)的区域中会陆续出现面积为 4 的十字形路障,求最短的通向永无路障的点的步数。若无法走到输出-1。

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int tox[6]={0,1,0,-1,0,0},toy[6]={0,0,1,0,-1,0};
int n,a[401][401],b[401][401];
struct node
{
	int x,y,t;//x,y坐标,t时间
	node() {x=y=t=0;}
}que[400001];
inline void bfs()
{
	register int head(1),tail(1+1),i,j;
	while(head<tail)
	{
		for(i=1;i<=4;i++)
		{
			int x1=que[head].x+tox[i];//入队 
			int y1=que[head].y+toy[i];
			if(x1<0 || y1<0)
			{
				continue;
			}
			if(a[x1][y1]==-1)//-1就是安全的格子了,如果到达了,那就是安全的格子 
			{
				cout<<que[head].t+1;//输出所用时间 
				return;
			}
			if(b[x1][y1]!=0 || que[head].t+1>=a[x1][y1])//如果已经走过,流星雨砸的时间在走到这个点之前 
			{
				continue;//不能走 
			}
			que[tail].t=que[head].t+1;//时间+1 
			que[tail].x=x1;
			que[tail++].y=y1;
			b[x1][y1]=1;//走过了 
		}
		head++;
	}
	cout<<-1<<endl;
}
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	register int i,j;
	cin>>n;
	memset(a,-1,sizeof(a));
	for(i=1;i<=n;i++)
	{
		int x,y,t;
		cin>>x>>y>>t;
		for(j=1;j<=5;j++)//五个方向位,注意0,0也要算 
		{
			int x1=x+tox[j];
			int y1=y+toy[j];
			if(x1<0 || y1<0)
			{
				continue;
			}
			if(a[x1][y1]!=-1)//如果没被砸过 
			{
				a[x1][y1]=min(a[x1][y1],t);//更新这块地被砸的时间 
			}
			else
			{
				a[x1][y1]=t;//更新这块地被砸的时间 
			}
		}
	}
	b[1][1]=1;//标记 
	bfs();//广♂搜 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Apro1066/article/details/83869162