List Leaves树的层序遍历

mid-14. List Leaves (15 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

思路: 根结点肯定不是其他节点的孩子,所以样例中未出现的3就是根结点。构造出二叉树,并使用队列层序输出。采用C++队列操作。

#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<queue>
using namespace std;
queue<int> q;


struct TreeNode
{
	int left;
	int right;
}T[10];
int check[10];//开一个标记数组


int Buildtree(struct TreeNode T[])
{
	int n,i,Root=-1;
	char cl,cr;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("\n%c %c",&cl,&cr); 
		if(cl!='-')//非空就存入
		{
			T[i].left =cl-'0';//字符转化为数字 
			check[T[i].left ]=1;/标记已存入
		}
		else T[i].left =-1;
		if(cr!='-')
		{
			T[i].right =cr-'0';
			check[T[i].right ]=1;
		}
		else T[i].right =-1;
	}
	for(i=0;i<n;i++)
	{
		if(check[i]==0)//遇到头节点就退出 
		break;
	}
	Root=i;//未被存入的就是头节点 
	return Root;
}

void Output_leaves(int Root)
{
	int count=0;
	int temp;
	if(Root==-1)return;
	q.push(Root);
	while(!q.empty())
	{
	temp=q.front();//队头给temp
	q.pop();//出队 
	if(T[temp].left ==-1&&T[temp].right ==-1)//若是叶子节点,则输出
	{
		if(count++!=0)
		{
			printf(" ");//输出空格用的 
		}
		printf("%d",temp);
	}
	if(T[temp].left !=-1)q.push(T[temp].left);//左孩子进队 
	if(T[temp].right !=-1)q.push(T[temp].right);//右孩子进队 
    }
}                                          


int main()
{
	int Root;
	Root=Buildtree(T);
	Output_leaves(Root);
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/Aa13527916708/article/details/84801512
今日推荐