03-树2 List Leaves(25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

#include<stdio.h>
#include<stdlib.h>
#define MAXSIZE 15
typedef struct Node {
	char right;
	char left;
}node;

typedef struct line {
	int b[MAXSIZE];
	int f;
	int r;
}Line,*qLine;

typedef struct nodes{
	node a[MAXSIZE];
}Nodes, *qNode;

void Push(qLine *p, int X);
int Pop(qLine *p);
int main()
{
	
	int count = 0;
	scanf("%d\n", &count);
	
	qNode q = (Nodes *)malloc(sizeof(Nodes));
	for (int i = 0;i < count;i++) {
		scanf("%c %c ",&q->a[i].left, &q->a[i].right);
	}
	int top = 0,n=0;
	for (int i = 0;i < count;i++) {
		for (int j = 0;j < count;j++) {
			if (top == q->a[j].left-'0' || top == q->a[j].right-'0') {
				top = j;
				n = 0;
				break;
			}
			n++;
			
		}
		if (n >= count - 1) {
			break;
		}
	}

	qLine p = (Line *)malloc(sizeof(Line));
	p->f = 0;
	p->r = 0;
	Push(&p,top);

int l = 0;
	while (top!=-1)
	{
		l++;
		top = Pop(&p);
		if (q->a[top].left != '-') {
			Push(&p, (q->a[top].left - '0'));
		}
		if (q->a[top].right != '-') {
			Push(&p, (q->a[top].right - '0'));
		}
		if (q->a[top].left == '-'&&q->a[top].right == '-') {
			if (l != count) {
				printf("%d ", top);
			}
			else {
				printf("%d", top);
			}
		}
	}

    return 0;
}


void Push(qLine *p,int X) {
	if (((*p)->r- (*p)->f + 1+ MAXSIZE) % MAXSIZE != 0) {
		(*p)->r++;
		(*p)->b[(*p)->r] = X;
		
	}
}

int Pop(qLine *p) {
	int j = -1;
		if ((*p)->f!=(*p)->r) {
			(*p)->f++;
			j=(*p)->b[(*p)->f];
			
		}
	return j;
}



猜你喜欢

转载自blog.csdn.net/qq_29718605/article/details/80262170
今日推荐