03-树2 List Leaves(25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/centralunit/article/details/89094775

03-树2 List Leaves(25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( 10 ) N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 0 to N 1 N−1 . Then N N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

#include<iostream>
#include<cstdlib>
#define Tree int
#define MaxSize 10
#define Null -1

using namespace std;

//定义树结构
struct TreeNode {
	Tree Left;
	Tree Right;
}T[MaxSize];

//定义队列结构
typedef struct QueueNode {
	int Data;
	struct QueueNode *Next;
}QueueNode, *Queue;

//初始化队列
Queue initQueue(void) {
	Queue q = (Queue)malloc(sizeof(QueueNode));
	q->Next = NULL;
	return q;
}

//判断队列是否为空
int isQueueEmpty(Queue Q) {
	return Q->Next == NULL ? 1 : 0;
}

//入队
void enQueue(int data, Queue Q) {
	Queue p = initQueue(), q = Q;
	p->Data = data;
	while (!isQueueEmpty(q)) q = q->Next;
	q->Next = p;
}

//出队
int deQueue(Queue Q) {
	if (isQueueEmpty(Q)) return NULL;
	Queue q = Q, p;
	int result;
	p = Q->Next;
	q = p->Next;
	result = p->Data;
	Q->Next = q;
	free(p);
	return result;
}

//输入数据并返回该数根节点的位置
Tree BuildTree(struct TreeNode T[]) {
	int n, check[MaxSize], i, root = Null;
	char tempLeft, tempRight;
	scanf("%d", &n);
	if (n) {
		for (i = 0; i < n; i++) check[i] = 0;
		for (i = 0; i < n; i++) {
			//接收上一次输入后残留的\n,防止对后面的输入产生影响
			tempLeft = getchar();
			scanf("%c %c", &tempLeft, &tempRight);
			if (tempLeft != '-') {
				T[i].Left = tempLeft - '0';
				check[T[i].Left] = 1;
			}
			else T[i].Left = Null;
			if (tempRight != '-') {
				T[i].Right = tempRight - '0';
				check[T[i].Right] = 1;
			}
			else T[i].Right = Null;
		}
		for (i = 0; i < n; i++) if (check[i] == 0) break;
		root = i;
	}
	return root;
}

//找到所有叶子结点,并按照从上至下、从左至右的顺序输出它们的索引
void FindLeaves(Tree R) {
	if (R == Null) return;
	bool isFirst = true;
	Tree temp = R;
	Queue Q = initQueue();
	enQueue(R, Q);
	while (!isQueueEmpty(Q)) {
		temp = deQueue(Q);
		if (T[temp].Left == Null && T[temp].Right == Null) {
			if (isFirst) {
				cout << temp;
				isFirst = false;
			}
			else cout << ' ' << temp;
		}
		if (T[temp].Left != Null) enQueue(T[temp].Left, Q);
		if (T[temp].Right != Null) enQueue(T[temp].Right, Q);
	}
	cout << endl;
}

int main(void) {
	Tree R;
	R = BuildTree(T);
	FindLeaves(R);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/centralunit/article/details/89094775
今日推荐