poj 3494 Largest Submatrix of All 1’s

Largest Submatrix of All 1’s
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 7700   Accepted: 2779
Case Time Limit: 2000MS

Description

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ mn ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with n numbers. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output

0
4
题意:找出最大子矩阵
思路:单调栈,找出每一行每一个元素上的累计高度,再一行一行的考虑。
AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
#define INF 0x3f3f3f3f
#define N_MAX 2000+20
typedef long long ll;
int n,m,h[N_MAX][N_MAX],Map[N_MAX][N_MAX];
int st[N_MAX],L[N_MAX],R[N_MAX];
ll solve(const int *h,const int& n) {
    int t = 0;
    for (int i = 0; i < n;i++) {
        while (t > 0 && h[st[t - 1]] >= h[i])t--;
        L[i] = t == 0 ? 0 : st[t - 1] + 1;
        st[t++] = i;
    }
    t = 0;
    for (int i = n - 1; i >= 0;i--) {
        while (t > 0 && h[st[t - 1]] >= h[i])t--;
        R[i] = t == 0 ? n : st[t - 1];
        st[t++] = i;
    }
    ll res = 0;
    for (int i = 0; i < n;i++) {
        res = max(res, (ll)h[i] * (R[i] - L[i]));
    }
    return res;
}

void prep() {
    for (int i = 0; i < m; i++)h[0][i] = Map[0][i];
    for (int i = 1; i < n;i++) {
        for (int j = 0; j < m;j++) {
           if(Map[i][j])h[i][j] = Map[i][j] + h[i - 1][j];
           else h[i][j] = 0;
        }
    }

}

int main() {
    while (scanf("%d%d",&n,&m)!=EOF){
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                scanf("%d",&Map[i][j]);
            }
        }
        prep();
        ll res = 0;
        for (int i = 0; i < n;i++) {
            res=max(res,solve(h[i],m));
        }
        printf("%lld\n",res);
    }    
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/ZefengYao/p/9021619.html