2016亚洲区域赛北京赛区K JiLi Number

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/DADDY_HONG/article/details/83345677

Driver Ji likes the digit “1”. He has an accumulator which shows the sum of input number. He lists all of positive number no more than N and starts counting from one, two, three . . . Every time he counts a number he will add the number of digit “1” in this number to accumulator at the same time. The amazing thing happens! At some times, when he finishes counting a number X, the number which on the accumulator is X exactly, he will regard X as “JiLi Number” which means lucky number. Now he wants to know the number of “JiLi Numbers” and the biggest “JiLi Number” no more than N.

Input

There are several test cases and the each test case is a line contains an positive integer N, (1 < N ≤ 10100)

Output

For each test case, output two integers which donates the number of “JiLi Numbers” and the biggest “JiLi Number”.

Sample Input

1

100000000000

Sample Output

1 1

83 1111111110

差一点点儿......真的是没干劲啊。

找出规律:

n为1ex-1时,数字1的个数为,x*1e(x-1);

x为10之后,数字增长就无法赶超数字1的个数了,也就是说之后不会再有吉利数了。

虽然感受到了这个关键点,还是没敢打表直接做是怎么回事???难以置信这道题怎么这么玄学。

#include <cstdio>
#include <cstring>

const int maxn=110;

char s[maxn];

long long m[83]={
1,
199981,
199982,
199983,
199984,
199985,
199986,
199987,
199988,
199989,
199990,
200000,
200001,
1599981,
1599982,
1599983,
1599984,
1599985,
1599986,
1599987,
1599988,
1599989,
1599990,
2600000,
2600001,
13199998,
35000000,
35000001,
35199981,
35199982,
35199983,
35199984,
35199985,
35199986,
35199987,
35199988,
35199989,
35199990,
35200000,
35200001,
117463825,
500000000,
500000001,
500199981,
500199982,
500199983,
500199984,
500199985,
500199986,
500199987,
500199988,
500199989,
500199990,
500200000,
500200001,
501599981,
501599982,
501599983,
501599984,
501599985,
501599986,
501599987,
501599988,
501599989,
501599990,
502600000,
502600001,
513199998,
535000000,
535000001,
535199981,
535199982,
535199983,
535199984,
535199985,
535199986,
535199987,
535199988,
535199989,
535199990,
535200000,
535200001,
1111111110
};

int main()
{
     while(~scanf("%s",s)){
          int len=strlen(s);
          if(len>10){
               printf("83 1111111110\n");
               continue;
          }
          long long num=0;
          int i;
          for(int i=0;i<len;++i){
               num*=10;
               num+=(s[i]-'0');
          }
          for(i=0;i<83;++i)
               if(num<m[i]) break;
          printf("%d %lld\n",i,m[i-1]);
     }

     return 0;
}

猜你喜欢

转载自blog.csdn.net/DADDY_HONG/article/details/83345677