K-th Number

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

主席树模板题

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>

using namespace std;

const int MAXN = 100000 + 10;
int a[MAXN], b[MAXN];
int rt[MAXN], sum[MAXN << 5], lc[MAXN << 5], rc[MAXN << 5];
int cnt, p;

void build(int &t, int l, int r)
{
	t = ++cnt;
	if(l == r)
		return;
	int mid = (l + r) >> 1;
	build(lc[t], l, mid);
	build(rc[t], mid + 1, r);
}

int modify(int rt, int l, int r)
{
	int rtt = ++cnt;
	lc[rtt] = lc[rt], rc[rtt] = rc[rt], sum[rtt] = sum[rt] + 1;
	if(l == r)
		return rtt;
	int mid = (l + r) >> 1;
	if(p <= mid)
		lc[rtt] = modify(lc[rtt], l, mid);
	else
		rc[rtt] = modify(rc[rtt], mid + 1, r);
	return rtt;
}
int query(int rtl, int rtr, int l, int r, int k)
{
	int ans;
	int mid = (l + r) >> 1;
	int x = sum[lc[rtr]] - sum[lc[rtl]];
	if(l == r)
		return l;
	if(x >= k)
		ans = query(lc[rtl], lc[rtr], l, mid, k);
	else
		ans = query(rc[rtl], rc[rtr], mid + 1, r, k - x);
	return ans;
}
int main()
{
	int n, m;
	scanf("%d %d", &n, &m);
	for(int i = 1; i <= n; i ++)
		scanf("%d", &a[i]), b[i] = a[i];
	sort(b + 1, b + n + 1);
	int len = unique(b + 1, b + n + 1) - b - 1;
	build(rt[0], 1, len);
	for(int i = 1; i <= n; i ++)
	{
		p = lower_bound(b + 1, b + n + 1, a[i]) - b;
		rt[i] = modify(rt[i - 1], 1, len);
	}
	int x, y ,k;
	while(m --)
	{
		scanf("%d %d %d", &x, &y, &k);
		printf("%d\n", b[query(rt[x - 1], rt[y], 1, len, k)]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ant_e_zz/article/details/81672942