POJ1922 Ride to School【模拟+贪心】

Ride to School

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 24162   Accepted: 9617

Description

Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus – Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike. 

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit – he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one. 

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan. 

Input

There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format: 

Vi [TAB] Ti 

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti. 

Output

Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

Sample Input

4
20 0
25 -155
27 190
30 240
2
21 0
22 34
0

Sample Output

780
771

Source

Beijing 2004 Preliminary@POJ

扫描二维码关注公众号,回复: 4347840 查看本文章

问题链接:POJ1922 Ride to School

问题描述:起点与终点相隔4500米。现Charley 需要从起点骑车到终点。但是,他有个习惯,沿途需要有人陪伴,即以相同的速度, 与另外一个人一起骑。而当他遇到以更快的速度骑车的人时,他会以相应的速度跟上这个更快的人。先给定所有与Charley 同路的人各自的速度与出发时间,问Charley 以这种方式跟人,骑完4500米需要多少时间。得出的结果若是小数,则向上取整。

解题思路:每次Charley选择的都是当前最快的单车,而且Charley最后一定是和那个最快到达Yanyuan的单车同时到达,因为最早到达的人,一定会赶上查理,而查理就会跟上他一起到达。无视负时间出发的单车(因为Charley还没到的时候单车就走了,如果速度比他快,他永远也追不上。速度比他慢的话,追上了也没影响), 所以我们只要看看比Charley晚出发的单车谁最快到达Yanyuan,Charley最后肯定是跟着这辆车,最后的时间就是Charley到达的时间。

AC的C++程序:

#include<iostream>
#include<algorithm>
#include<cmath>

using namespace std;

int main()
{
	int n;
	while(~scanf("%d",&n)&&n)
	{
		double ans=999999999,vi,ti;
		while(n--)
		{
			scanf("%lf%lf",&vi,&ti);
			if(ti<0) continue;//跳过时间为负的
			double temp=4.5/vi*3600+ti;//跟上这辆车所需的时间
			ans=min(ans,temp);//取短的时间 
		}
		printf("%d\n",(int)ceil(ans));
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/84653423
今日推荐