Ride to school(注意精度)

版权声明:转载请注明出处链接 https://blog.csdn.net/qq_43408238/article/details/88747801

Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus - Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike.

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit - he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one.

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.

Input

There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:

Vi [TAB] Ti

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.

Output

Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

Sample Input

4
20 0
25 -155
27 190
30 240
2
21 0
22 34
0

Sample Output

780
771

这个题目一开始没读懂,后来发现:就是取最快到达终点的时间啊,也就是取所有时间中最少的,其中有个优化就是关于时间为负时,不用处理。然而呢,还是WA,我开始怀疑自己的思路是不是不正确啊,然后我参考别人的代码发现差不多啊,思路没错,为什么还不对?

我逐一对比发现一个问题:就是对数据的处理上,速度是千米每小时,时间是秒,肯定要进行单位的转换吧,问题就出在这儿。

错误代码:

#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<cmath>
#include <algorithm>
#include <stdlib.h>
#include <cstdio>
#include<sstream>
#include<cctype>
#include <set>
#include<queue>
#include <map>
#include <iomanip>
typedef long long ll;
using namespace std;
struct node
{
    double x,y;
};
int main()
{
    //freopen("input.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    ll m;double t,v;
    while(cin>>m)
    {
        double min1=10000000;
        if(m==0) return 0;
        for(ll i=0;i<m;i++)
        {
            cin>>v>>t;
            if(t<0) continue;
            v=v/3.6;//注意这儿
            t=t+4500*1.0/v;//还有这儿
            if(t<min1) min1=t;
        }
        cout<<ceil(min1)<<endl;;
    }
}

      AC代码:

#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<cmath>
#include <algorithm>
#include <stdlib.h>
#include <cstdio>
#include<sstream>
#include<cctype>
#include <set>
#include<queue>
#include <map>
#include <iomanip>
typedef long long ll;
using namespace std;
struct node
{
    double x,y;
};
int main()
{
    //freopen("input.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    ll m;double t,v;
    while(cin>>m)
    {
        double min1=10000000;
        if(m==0) return 0;
        for(ll i=0;i<m;i++)
        {
            cin>>v>>t;
            if(t<0) continue;
            t=t+4.5*3600/v;//再看这儿,对比一下
            if(t<min1) min1=t;
        }
        cout<<ceil(min1)<<endl;;
    }
}

        总结:

       关于精度亏损问题,我虽然在做题的时候也吃过亏,但没放心上,以后做题遇见关于浮点的运算要警醒!

猜你喜欢

转载自blog.csdn.net/qq_43408238/article/details/88747801