Network(UVA-315)求割点

题目:UVA-315

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The linesare bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate.

The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line

of each block there is the number of places

N<100. Each of the next at mostNlines contains thenumber of a place followed by the numbers of some places to which there is a direct line from this place.These at mostNlines completely describe the network, i.e., each direct connection of two places in

the network is contained at least in one row. All numbers in one line are separated by one space. Eachblock ends with a line containing just ‘0’. The last block has only one line withN= 0.

Output

The output contains for each block except the last in the input file one line containing the number ofcritical places.

Sample Input

5

5 1 2 3 4

0

6

2 1 3

5 4 6 2

0

0

Sample Output

1

2

题意:一个无向图,求其中的割点有多少个。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;

const int maxn = 10010;
struct Edge
{
    int to,next;
}edge[maxn];
int head[maxn],tot;
int Low[maxn],DFN[maxn];
int Index,root;
bool Instack[maxn];
bool cut[maxn];
void addedge(int u,int v)
{
    edge[tot].to = v;
    edge[tot].next = head[u];
    head[u] = tot ++;
}

void Tarjan(int u,int pre)
{
    int v;
    Low[u] = DFN[u] = ++ Index;
    Instack[u] = true;
    int son = 0;
    for(int i = head[u];i != -1;i = edge[i].next)
    {
        v = edge[i].to;
        if(v == pre) continue;
        if(!DFN[v])
        {
            Tarjan(v,u);
            son ++;
            if(Low[u] > Low[v])Low[u] = Low[v];
            if(u == root && son > 1)cut[u] = true;
            if(u != root && Low[v] >= DFN[u])
            {
                cut[u] = true;
            }
        }
        else Low[u] = min(DFN[v],Low[u]);
    }
}

int main()
{
    int n;
    int u,v;
    while(cin >> n && n)
    {
        memset(head,-1,sizeof (head));
        memset(cut,false,sizeof(cut));
        memset(Low,0,sizeof(Low));
        memset(DFN,0,sizeof(DFN));
        Index = 0;
        tot = 0;
        root = 1;
        while(cin >> u && u)
        {
            while(getchar() != '\n')
            {
                cin >> v;
                addedge(u,v);
                addedge(v,u);
            }
        }
        Tarjan(1,-1);
        int ans = 0;
        for(int i = 1;i <= n;i ++)
        {
            if(cut[i]) ans ++;
        }
        cout << ans << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guagua_de_xiaohai/article/details/84707547
今日推荐