hdu 1690

Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10038    Accepted Submission(s): 2742


 

Problem Description

Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.

 

Input

The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.

 

Output

For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.

 

Sample Input

 

2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4

 

Sample Output

 

Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.

 

Source

2008 “Sunline Cup” National Invitational Contest

 

Recommend

wangye

 

Statistic | Submit | Discuss | Note

注意数据范围过大,不能用0x3f3f3f3f,0x3f3f3f3f只能到1e9

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define inf  0x7fffffffffffffff
#define ll long long
#define maxn 300
using namespace std;
int n,m;
ll l1,l2,l3,l4,c1,c2,c3,c4;
ll dis[maxn][maxn];
ll x[maxn];
void init()
{//memset(dis,0,sizeof(dis));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        dis[i][j]=i==j?0:inf;

}
void floyd()
{
    for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        if(dis[i][k]+dis[k][j]<dis[i][j]&&dis[i][k]<inf&&dis[k][j]<inf)
        dis[i][j]=dis[i][k]+dis[k][j];

}

int main()
{
    int t;
    scanf("%d",&t);
int w=0;
    while(t--)
    {//memset(x,0,sizeof(x));
    w++;
        scanf("%lld%lld%lld%lld%lld%lld%lld%lld",&l1,&l2,&l3,&l4,&c1,&c2,&c3,&c4);
        scanf("%d%d",&n,&m);
        init();
        for(int i=1;i<=n;i++)
         {scanf("%lld",&x[i]);

    }


    for(int i=1;i<n;i++)
        for(int j=i+1;j<=n;j++)
       {
        if(abs(x[j]-x[i])<=l1)
        dis[i][j]=dis[j][i]=c1;
    else if(abs(x[i]-x[j])<=l2)
        dis[i][j]=dis[j][i]=c2;
    else if(abs(x[i]-x[j])<=l3)
        dis[i][j]=dis[j][i]=c3;
    else if(abs(x[i]-x[j])<=l4)
        dis[i][j]=dis[j][i]=c4;
    else
        dis[i][j]=dis[j][i]=inf;
}
floyd();

printf("Case %d:\n",w);
while(m--)
{int u,v;
    scanf("%d%d",&u,&v);

   if(dis[u][v]!=inf)

 printf("The minimum cost between station %d and station %d is %lld.\n",u,v,dis[u][v]);
 else
 printf("Station %d and station %d are not attainable.\n",u,v);
}
    }
return 0;
    }

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/84589796