HDOJ_1008_Elevator

elevator:电梯

denote:vt.  指代; 预示; 代表; 意思是;

compute:v.  计算,估算; 推断; 用计算机计算;  n.  计算;

Font Size:

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

AC代码:
#include <iostream>
#include <cstdio>
#define Max 110
using namespace std;

int a[Max];

int main(void)
{
    freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        long long time=0;
        
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(i==1)
                time+=a[i]*6;
            else
            {
                if(a[i]>a[i-1])
                    time+=6*(a[i]-a[i-1]);
                else
                    time+=4*(a[i-1]-a[i]);
            }
        }
        
        time+=5*n;
        printf("%lld\n",time);
    }
    
    
    fclose(stdin);
    return 0;
 } 

猜你喜欢

转载自www.cnblogs.com/phaLQ/p/10030124.html