C~K要找女朋友了!!!

C~K要找女朋友了!!!

Time Limit: 1000 ms  Memory Limit: 131072 KiB

Problem Description

临近11.11,C~K看见周围的朋友一个个的都脱单或者正准备脱单了,C~K也想要找一个女朋友了(听说国家会分配?)。MeiK听说了这件事情,表
示C~K终于开悟了,所以他整理了一份候选人名单给C~K。可是C~K心里有自己心动女生的身高区间和年龄限制,所以他想把符合条件的女生
的信息给筛选出来,但是这可是难住了C~K,事关C~K的幸福,你能帮帮他吗?
ps:由于MeiK比较傻,所以名单里可能会有重复的女生的信息,若信息重复,则第一次输入为有效信息。

Input

多组输入。
第一行输入MeiK的候选人名单里有N个人(N<100000)。
第二行输入四个整数a,b,c,d。分别表示C~K心动女生的身高的最小值和最大值,年龄的最小值和最大值。(题目保证a<=b,c<=d)
接下来输入N行,每行表示一个女生的信息(姓名,身高,年龄,联系方式)

ps:联系方式不超过11个字符。

Output


对于每一组输入,第一行输出一个n,表示符合条件的女生的数量。
接下来的n行,每一行输出一个符合条件的女生的信息。
输出顺序按身高从低到高排序,若身高相同,则按年龄从高到底排序,若年龄也相同,则按照输入顺序输出。

Sample Input

4
160 170 20 22
女神1 161 19 11111
女神2 167 20 22222
女神2 167 20 22222
女神3 163 21 33333

Sample Output

2
女神3 163 21 33333
女神2 167 20 22222

Hint

import java.util.*;

class St
{
	String name;
	int he, age;
	String tel;
	public St(String name, int he, int age, String tel) {
		super();
		this.name = name;
		this.he = he;
		this.age = age;
		this.tel = tel;
	}
	
	@Override
	public int hashCode() {
		final int prime = 31;
		int result = 1;
		result = prime * result + age;
		result = prime * result + he;
		result = prime * result + ((name == null) ? 0 : name.hashCode());
		result = prime * result + ((tel == null) ? 0 : tel.hashCode());
		return result;
	}

	@Override
	public boolean equals(Object obj) {
		if (this == obj)
			return true;
		if (obj == null)
			return false;
		if (getClass() != obj.getClass())
			return false;
		St other = (St) obj;
		if (age != other.age)
			return false;
		if (he != other.he)
			return false;
		if (name == null) {
			if (other.name != null)
				return false;
		} else if (!name.equals(other.name))
			return false;
		if (tel == null) {
			if (other.tel != null)
				return false;
		} else if (!tel.equals(other.tel))
			return false;
		return true;
	}

	@Override
	public String toString() {
		return  name + " " + he + " " + age + " " + tel ;
	}
	
}

public class Main
{
	public static void main(String[] args) {
		int n, m, i, a, b, c, d;
		String name;
		int he, age;
		String tel;
		Scanner re = new Scanner(System.in);
		while(re.hasNext())
		{
			n = re.nextInt();
			a = re.nextInt();
			b = re.nextInt();
			c = re.nextInt();
			d = re.nextInt();
			Set<St>set = new HashSet<St>();
			for(i = 0; i < n; i++)
			{
				name = re.next();
				he = re.nextInt();
				age = re.nextInt();
				tel = re.next();
				St s1 = new St(name, he, age,tel);
				if((s1.age>=c&&s1.age<=d)&&(s1.he>=a&&s1.he<=b))
				set.add(s1);
			}
			int k = set.size();
			System.out.println(k);
			List<St>list = new ArrayList<St>(set);
			Collections.sort(list, new Comparator<St>() {
				public int compare(St t1, St t2)
				{
					if(t1.he==t2.he)
					{
						return t2.age-t1.age;
					}
					else return t1.he-t2.he;
				}
			});
			Iterator<St> it = list.iterator();
			while(it.hasNext())
			{
				System.out.println(it.next());
			}
		}
		re.close();
	}
}

猜你喜欢

转载自blog.csdn.net/kksimida/article/details/80040657