1044 Shopping in Mars (25)(25 point(s))

版权声明:本文为博主原创文章,需表明来源,方可随意转载。 https://blog.csdn.net/qq_36589706/article/details/81707086

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M\$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M\$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M\$15. We may have 3 options:

  • 1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  • 2.Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  • 3.Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N(<=10^5^), the total number of diamonds on the chain, and M (<=10^8^), the amount that the customer has to pay. Then the next line contains Npositive numbers D~1~ ... D~N~ (D~i~<=10^3^ for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= jsuch thatD~i~ + ... + D~j~ = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs ofi <= jsuch thatD~i~ + ... + D~j~ > M with (D~i~ + ... + D~j~ - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

 这种解法的思路很好

1、把一个非递增数列转化成递增数列(求和),以便利用二分法;

2、sum[j-1] - sum[ i-1] = S, 转化为sum[j-1] = sum[i-1] + S,二分法寻找 sum[ j-1]。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100010;
int sum[maxn];
int n, S, nearS=100000010;
int upper_bound( int left, int right, int num){//寻找第一个大于num的数
	int mid;
	while(left<right){
		mid=(right+left)/2;
		if(sum[mid]>num){
			right=mid;
		}else{
			left=mid+1;
		}
	}
	return left;
}
int main(){
	scanf("%d%d", &n, &S);
	sum[0]=0; 
	for(int i=1; i<=n; i++){
		scanf("%d", &sum[i]);
		sum[i]+=sum[i-1];
	}
	for(int i=1; i<=n; i++){
		int j=upper_bound(i-1, n+1, sum[i-1]+S);
		if(sum[j-1]-sum[i-1]==S){ //sum[j-1]可能就是要找的数 
			nearS=S;
			break;
		}else if(j<=n&&sum[j]-sum[i-1]<nearS){ //若没找这个数,就存下大于它的第一个数 
			nearS=sum[j]-sum[i-1];
		}
	}
	for(int i=1; i<=n; i++){
		int j=upper_bound(i-1, n+1, sum[i-1]+nearS);
		if(sum[j-1]-sum[i-1]==nearS){
			printf("%d-%d\n",i, j-1);
		}
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36589706/article/details/81707086
今日推荐