1044 Shopping in Mars (25)(25 分)(C++)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M\$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M\$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M\$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).\

  1. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).\
  2. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).\

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10^5^), the total number of diamonds on the chain, and M (<=10^8^), the amount that the customer has to pay. Then the next line contains N positive numbers D~1~ ... D~N~ (D~i~<=10^3^ for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that D~i~ + ... + D~j~ = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that D~i~ + ... + D~j~ > M with (D~i~ + ... + D~j~ - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

解题思路:不直接存每个元素的值,而是存每个元素的前几项之和,这样子不难看出序列为升序排列,很容易想到二分法查找差值为m的数,这里查找了两次,第一次查找的时候记录一下大于m的最小值,以便第二次查找

#include <iostream>
#include <vector>
#include <cstdio>
using namespace std;
int n,m;
int main(){
    scanf("%d %d",&n,&m);
    std::vector<int> v(n+1);
    std::vector<int> result;
    int resultmin=999999999;
    bool flag=false;
    v[0]=0;
    for(int i=1;i<=n;i++){
        int temp;
        scanf("%d",&temp);
        v[i]=temp+v[i-1];
    }
    for(int i=0;i<=n;i++){
        int low=i,high=n,tempresult=-1;
        while(low<=high){
            int mid=(high+low)/2;
            if(v[mid]-v[i]==m){
                tempresult=mid;
                flag=true;
                break;
            }
            else if(v[mid]-v[i]>m){
                high=mid-1;
                if((v[mid]-v[i])<resultmin)
                    resultmin=v[mid]-v[i];
            }
            else
                low=mid+1;
        }
        if(tempresult!=-1){
            result.push_back(i+1);
            result.push_back(tempresult);
        }
    }
    if(flag==false){
        m=resultmin;
        for(int i=0;i<=n;i++){
            int low=i,high=n,tempresult=-1;
            while(low<=high){
                int mid=(high+low)/2;
                if(v[mid]-v[i]==m){
                    tempresult=mid;
                    break;
                }
				else if(v[mid]-v[i]>m)
					high=mid-1;
				else
					low=mid+1;
			}
            if(tempresult!=-1){
                result.push_back(i+1);
                result.push_back(tempresult);
            }
        }
    }
    for(int i=0;i<result.size();i=i+2)
        printf("%d-%d\n",result[i],result[i+1]);
    system("pause");
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/81985879
今日推荐