找到第n个数,

find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15498    Accepted Submission(s): 4884


 

Problem Description

假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?

 

Input

输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。

 

Output

对于每个N,输出S中第N个对应的数字.

 

Sample Input

 

6 1 2 3 4 5 10

 

Sample Output

 

1 1 2 1 2 4

 这道题需要分析一下,当时比赛的时候由于状态,没想出来,

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int i,j,t,m,a[9]={9,1,2,3,4,5,6,7,8};
    cin>>t;
    while(t--)
    {
        int s=0,n=0;
        cin>>m;
        for(i=1;s<m;i++)
        {
            s=s+i;
        }
        s=s-i;//得到m所在层数的前一层, 
        n=m-(s+1);   //找到这一层
        printf("%d\n",a[(n)%9]);     对9取余数
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41325698/article/details/82011746
今日推荐