2016 ICPC大连赛区 [Cloned] H - To begin or not to begin

A box contains black balls and a single red ball. Alice and Bob draw balls from this box without replacement, alternating after each draws until the red ball is drawn. The game is won by the player who happens to draw the single red ball. Bob is a gentleman and offers Alice the choice of whether she wants to start or not. Alice has a hunch that she might be better off if she starts; after all, she might succeed in the first draw. On the other hand, if her first draw yields a black ball, then Bob’s chances to draw the red ball in his first draw are increased, because then one black ball is already removed from the box. How should Alice decide in order to maximize her probability of winning? Help Alice with decision.

Input

Multiple test cases (number of test cases≤50), process till end of input.
For each case, a positive integer k (1≤k≤10^5) is given on a single line.

Output

For each case, output:
1, if the player who starts drawing has an advantage
2, if the player who starts drawing has a disadvantage
0, if Alice’s and Bob’s chances are equal, no matter who starts drawing
Sample Input

1
2
Sample Output

0
1
只分奇偶考虑
“ 2,if the player who starts drawing has a disadvantage ”为干扰项 先取不可能吃亏
找规律 下面统计先取的人的胜率
第一项为所有球个数
2 1/2
3 1/3+2/3*(1/2)=2/3
4 1/4+3/42/3(1/2)= 1/2
5 1/5+4/53/42/3=3/5 最后乘的那项为n-2的胜率

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int k;
int main(){
    while (~scanf("%d",&k)) {
        if(k&1)
            printf("0\n");
        else
            printf("1\n");
    }
}
 


猜你喜欢

转载自blog.csdn.net/qq_43409499/article/details/84178952
今日推荐