杭电ACM-1064 Financial Management

Financial Management

                                                                 Time Limit: 400/200 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                 Total Submission(s): 15770    Accepted Submission(s): 9255


Problem Description
Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
 

Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
 

Sample Input
 
  
100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75
 

Sample Output
 
  
$1581.42

水题,为了练翻译......没什么说的,求十二个月银行卡的平均余额,直接求就是了。别忘了加美元符号,没有其他格式要求。

AC代码如下:

#include <iostream>
using namespace std;
int main()
{
      double  a ,sum ;
      sum=0.00;                        //初始化
	for(int i=0;i<12;i++)
	{
	          cin >> a;
	  	  sum+=a;
	}
	cout<<"$"<<sum/12<<endl;     //为了方便,在这里直接除12了
    return 0 ;
}


猜你喜欢

转载自blog.csdn.net/qq_36791466/article/details/80455327
今日推荐