2021.1.4 星期一 Financial Management


《Financial Management》


题目
Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

输入格式

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

输出格式

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output
$1581.42

题意

算出12个月的平均账单。

思路
循环相加。

坑点
小数赋值0.0,小数乘小数不可能是整数。

代码

#include<stdio.h>
int main()
{
    
    
	double num=0.0;
    double sum=0.0;
	int i;
	for(i=0;i<12;i++)
	{
    
    
		scanf("%lf\n",&num);
		sum=sum+num;
	}
	
	printf("$%.2lf",sum/12.0);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Autumn_snow/article/details/112167503