1018: Give me the answer

1018: Give me the answer

时间限制: 1 Sec  内存限制: 32 MB
提交: 55  解决: 15
[提交][状态][讨论版][命题人:外部导入]

题目描述

Farmer John commanded his cows to search for different sets of numbers that sum to a given number.
The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that
sum to 7:
1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4
Help FJ count all possible representations for a given integer N (1 <= N <= 1 ,000,000)

输入

The first line of the input contains the number of test cases in the file. And t he first line of each case
contains one integer numbers n

输出

For each test case, output a line with the ans % 1000000000.

样例输入

1
7

样例输出

6

#include<stdio.h>
#define MAX 1000010
int a[MAX];
int main()
{
    int n, m, i;
    a[1] = 1;
    a[2] = 2;
    for(i = 3; i <= MAX; ++i)
    {
        if(i & 1)
            a[i] = a[i - 1] % 1000000000;
        else
            a[i] = (a[i - 1] + a[i / 2]) % 1000000000;
    }
    scanf("%d", &n);
    while(n--)
    {
        scanf("%d", &m);
        printf("%d\n", a[m]);
    }
    return 0;
}

  

 

猜你喜欢

转载自www.cnblogs.com/mjn1/p/9937017.html
me
今日推荐