AtCoder Beginner Contest 113 B - Palace

Problem Statement

A country decides to build a palace.

In this country, the average temperature of a point at an elevation of x meters is Tx×0.006 degrees Celsius.

There are N places proposed for the place. The elevation of Place i is Hi meters.

Among them, Princess Joisino orders you to select the place whose average temperature is the closest to A degrees Celsius, and build the palace there.

Print the index of the place where the palace should be built.

It is guaranteed that the solution is unique.

Constraints

  • 1≤N≤1000
  • 0≤T≤50
  • −60≤AT
  • 0≤Hi≤105
  • All values in input are integers.
  • The solution is unique.

Input

Input is given from Standard Input in the following format:

N
T A
H1 H2 … HN

Output

Print the index of the place where the palace should be built.


Sample Input 1

Copy

2
12 5
1000 2000

Sample Output 1

Copy

1
  • The average temperature of Place 1 is 12−1000×0.006=6 degrees Celsius.
  • The average temperature of Place 2 is 12−2000×0.006=0 degrees Celsius.

Thus, the palace should be built at Place 1.


Sample Input 2

Copy

3
21 -11
81234 94124 52141

Sample Output 2

Copy

3
#include<iostream>
#include<cmath>
using namespace std;

double s[100000];

int main()
{
	int n,m,j,k,i,t,ans,T,a,b;
	cin>>n;
	cin>>a>>b;		
	for (i=0;i<n;i++)
	{
		cin>>s[i];
		s[i]  = a - 0.006*s[i];
	}
	double min = 1000000000.0;
	for (i=0;i<n;i++)
	{
		if (fabs(s[i] - b)<= min)
		{
			min = fabs(s[i]-b);
			ans = i; 
		}
	}
	cout<<ans+1<<endl;
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_40763929/article/details/83869310
今日推荐