E - Just a Hook (线段树+区间更新)

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. 



Now Pudge wants to do some operations on the hook. 

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. 
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows: 

For each cupreous stick, the value is 1. 
For each silver stick, the value is 2. 
For each golden stick, the value is 3. 

Pudge wants to know the total value of the hook after performing the operations. 
You may consider the original hook is made up of cupreous sticks. 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. 
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. 
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind. 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example. 

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

线段树的lazy应用,不难,题意:刚开始 1 -- n 的钩子价值都为 1 ,q 次操作,将 [l,r] 变为 z 价值,最后问总和

#include <iostream>
#include<stdio.h>
#include<string.h>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
int n;
const int N=100001;
const int inf=0x3f3f3f;
int sum[N<<2];
int lazy[N<<2];
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int m)
{
    if(lazy[rt]!=inf)
    {
        lazy[rt<<1]=lazy[rt<<1|1]=lazy[rt];//lazy标记下移
        sum[rt<<1]=(m-(m>>1))*lazy[rt];//对半下分
        sum[rt<<1|1]=(m>>1)*lazy[rt];
        lazy[rt]=inf;//标记lazy为空
    }
}
void build(int l,int r,int rt)
{
    lazy[rt]=inf; //懒惰标记
    sum[rt]=1;//每个节点标记为1;
    if(l==r)
        return;
    int m=(r+l)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void updata(int a,int b,int c,int l,int r,int rt)
{
    if(a<=l&&b>=r)
    {
        lazy[rt]=c;//给lazy数组赋值
        sum[rt]=c*(r-l+1);//因为数值是直接覆盖,所以直接用lazy的值乘以长度就是这个节点的值
        return;
    }
    pushdown(rt,r-l+1);
    int m=(l+r)>>1;
    if(a<=m)
        updata(a,b,c,lson);
    if(b>m)updata(a,b,c,rson);
    pushup(rt);

}
int main()
{
    int t;
    int m;
    int f=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        build(1,n,1);
        scanf("%d",&m);
        while(m--)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            updata(a,b,c,1,n,1);
        }
        f++;
        printf("Case %d: The total value of the hook is %d.\n",f,sum[1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chen_zan_yu_/article/details/83536672