sincerit 2105 The Center of Gravity(三角形重心)

The Center of Gravity
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7178 Accepted Submission(s): 4177

Problem Description
Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What’s more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center
of gravity of the triangle?

Input
The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.

Output
For each case, print the coordinate, accurate up to 1 decimal places.

Sample Input
2
1.0 2.0 3.0 4.0 5.0 2.0
1.0 1.0 4.0 1.0 1.0 5.0
0

Sample Output
3.0 2.7
2.0 2.3

在平面直角坐标系中,重心的坐标是顶点坐标的算术平均数,
即其坐标为[(X1+X2+X3)/3,(Y1+Y2+Y3)/3];
空间直角坐标系——X坐标:(X1+X2+X3)/3,Y坐标:(Y1+Y2+Y3)/3,Z坐标:(Z1+Z2+Z3)/3.

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
int main() {
  double x1, y1, x2, y2, x3, y3;
  int n;
  while (cin >> n, n) {
    for (int i = 0; i < n; i++) {
      cin >> x1 >> y1 >> x2 >> y2 >> x3 >> y3;
      printf("%.1f %.1f\n", (x1+x2+x3)/3.0, (y1+y2+y3)/3.0);
    }
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/sincerit/article/details/83474182