ACM--三角形重心--HDOJ 2105--The Center of Gravity(FOR JAVA)

版权声明:MZ21G https://blog.csdn.net/qq_35793285/article/details/83990071

Problem Description

Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked 
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What's more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center 
of gravity of the triangle?

Input

The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.

Output

For each case, print the coordinate, accurate up to 1 decimal places.

Sample Input

2 1.0 2.0 3.0 4.0 5.0 2.0 1.0 1.0 4.0 1.0 1.0 5.0 0

Sample Output

3.0 2.7 2.0 2.3

重心的坐标是顶点坐标的算术平均

这道题注意键盘录入

只有在输入0时才能结束

AC代码:

import java.util.Scanner;

public class Main{

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		
		Scanner scanner = new Scanner(System.in);

		double x1,y1,x2,y2,x3,y3,res1,res2;
		
		while(scanner.hasNext()) {
			int N = scanner.nextInt();
			if(N ==0)
				break;
			while((N--)  != 0) {
				x1 = scanner.nextDouble();
				y1 = scanner.nextDouble();
				x2 = scanner.nextDouble();
				y2 = scanner.nextDouble();
				x3 = scanner.nextDouble();
				y3 = scanner.nextDouble();
				
				res1 = (x1+x2+x3) / 3;
				res2 = (y1+y2+y3) / 3;

				System.out.println(String.format("%.1f", res1) +" " + String.format("%.1f", res2));

			}			
		}
	
	}
}

猜你喜欢

转载自blog.csdn.net/qq_35793285/article/details/83990071