String of CCPC(ZOJ)

                                                   String of CCPC

BaoBao has just found a string of length consisting of 'C' and 'P' in his pocket. As a big fan of the China Collegiate Programming Contest, BaoBao thinks a substring of is "good", if and only if 'C', and 'P', where denotes the -th character in string . The value of is the number of different "good" substrings in . Two "good" substrings and are different, if and only if .

To make this string more valuable, BaoBao decides to buy some characters from a character store. Each time he can buy one 'C' or one 'P' from the store, and insert the character into any position in . But everything comes with a cost. If it's the -th time for BaoBao to buy a character, he will have to spend units of value.

The final value BaoBao obtains is the final value of minus the total cost of all the characters bought from the store. Please help BaoBao maximize the final value.

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integer (), indicating the length of string .

The second line contains the string () consisting of 'C' and 'P'.

It's guaranteed that the sum of over all test cases will not exceed .

Output

For each test case output one line containing one integer, indicating the maximum final value BaoBao can obtain.

Sample Input

3
3
CCC
5
CCCCP
4
CPCP

Sample Output

1
1
1

Hint

For the first sample test case, BaoBao can buy one 'P' (cost 0 value) and change to "CCPC". So the final value is 1 - 0 = 1.

For the second sample test case, BaoBao can buy one 'C' and one 'P' (cost 0 + 1 = 1 value) and change to "CCPCCPC". So the final value is 2 - 1 = 1.

For the third sample test case, BaoBao can buy one 'C' (cost 0 value) and change to "CCPCP". So the final value is 1 - 0 = 1.

It's easy to prove that no strategies of buying and inserting characters can achieve a better result for the sample test cases.

题目链接:
https://vjudge.net/problem/ZOJ-3985

题意描述:

给你一个由CP组成的字符串,允许你加入一个字母C或P,使字符串中的CCPC数量最多,其中CCPCCPC这个串中含有两个CCPC

解题思路:

首先把所有的CCPC判断一下,如果不满足CCPC那就判断CCC、CCP和CPC,其中CCC还要判断其后面是否为PC即可

程序代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
char str[200010];

int main()
{
	int i,T,n,sum,flag;
	
	scanf("%d",&T);
	while(T--)
	{
		sum=0;
		flag=0;
		scanf("%d%s",&n,str);
		for(i=0;i<n;i++)
		{
			if(str[i]=='C'&&str[i+1]=='C'&&str[i+2]=='P'&&str[i+3]=='C')
			{
				sum++;
				i+=2;
				continue;
			}
			if(flag==0)
			{
				if(str[i]=='C'&&str[i+1]=='C'&&str[i+2]=='C')
				{
					if(str[i+3]=='P'&&str[i+4]=='C')
						continue;
					sum++;
					flag=1;
				}
				if(str[i]=='C'&&str[i+1]=='C'&&str[i+2]=='P')
				{
					sum++;
					flag=1;
				}
				if(str[i]=='C'&&str[i+1]=='P'&&str[i+2]=='C')
				{
					sum++;
					flag=1;
				}
			}
		}
		printf("%d\n",sum);
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/83417180