Monthly Expense(二分)

Monthly Expense

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2… N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意:

给定一个序列n个数,分成m段,要求所有分的方案中,最大值最小

分析:

二分这个最大值,首先我们找到左边界右边界,因为是每种分法的最大值,所以最小是n个数中的最大的那个数单独作为一段,最大就是n个数求和作为一段,这样找的了左右边界,二分找最大值,按照这个最大值看能分成多少段和m作比较,如果小于m说明这个最大值过大使得段数小,否则说明最大值小。

code:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int main(){
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        int a[100010];
        int sum = 0;
        int maxa = 0;
        for(int i = 0; i < n; i++){
            scanf("%d",&a[i]);
            maxa = max(maxa,a[i]);
            sum += a[i];
        }
        int l = maxa,r = sum;
        while(l < r){
            int mid = l + r >> 1;
            int cnt = 0,s = 0;
            for(int i = 0; i < n; i++){
                s += a[i];
                if(s > mid){
                    s = a[i];
                    cnt++;
                }
            }
            if(cnt < m) r = mid;//太大,所以分的区间小于m
            else l = mid + 1;//太小,所以分的区间大于m
        }
        printf("%d\n",l);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/83056387
今日推荐