POJ-1330-Nearest Common Ancestors(LCA+倍增模板题)

题目链接:http://poj.org/problem?id=1330

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

 
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 
 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

给出n个节点,输出n个节点的最小公共祖先,注意一下根节点,LCA倍增直接就过了

ac:

//#pragma comment(linker, "/STACK:1024000000,1024000000") 

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<fstream>
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
//#define max(a,b) (a)>(b)?(a):(b)
//#define min(a,b) (a)<(b)?(a):(b) 
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
//std::ios::sync_with_stdio(false);
const int MAXN=10100;
const int INF=0x3f3f3f3f;
const ll mod=1e9+7;

struct node{
	int v,w,nxt;
	node(int _v=0,int _nxt=0):
	v(_v),nxt(_nxt){}
}edge[MAXN];
int head[MAXN],ecnt;
int fa[MAXN][30],deep[MAXN];
bool fat[MAXN];
int n,m;
void intt()
{
	clean(fat,0);
	clean(head,-1);
	clean(deep,0);
	clean(fa,-1);
	ecnt=0;
}
 
void add(int u,int v)
{
	edge[ecnt]=node(v,head[u]);
	head[u]=ecnt++;
}

void dfs(int u)
{
	for(int i=head[u];i+1;i=edge[i].nxt)
	{
		int temp=edge[i].v;
		if(deep[temp]==0)
		{
			deep[temp]=deep[u]+1;
			fa[temp][0]=u;
			int up=0,pre=u;
			while(fa[pre][up]>0)
			{
				fa[temp][up+1]=fa[pre][up];
				pre=fa[pre][up++];
			}
			dfs(temp);
		}
	}
}

int lca(int a,int b)
{
	if(deep[a]<deep[b])
		swap(a,b);
	int lim=log2(deep[a])+1;
	for(int i=lim;i>=0;--i)
	{
		if(deep[fa[a][i]]>=deep[b])
			a=fa[a][i];
	}
	if(a==b)
		return a;
	for(int i=lim;i>=0;--i)
	{
		if(fa[a][i]!=fa[b][i])
		{
			a=fa[a][i];
			b=fa[b][i];
		}
	}
	//cout<<a<<" "<<fa[a][0]<<endl;
	return fa[a][0];
}

int main()
{
	std::ios::sync_with_stdio(false);
	int T;
	cin>>T;
	while(T--)
	{
		intt();
		cin>>n;
		int a,b;
		for(int i=1;i<n;++i)
		{
			cin>>a>>b;
			fat[b]=1;
			add(a,b);
		}
		int rt;
		for(int i=1;i<=n;++i)
		{
			if(fat[i]==0)
			{
				rt=i;
				break;
			}
		}
		deep[rt]=1;
		//cout<<rt<<endl;
		dfs(rt);
		cin>>a>>b;
		cout<<lca(a,b)<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40482358/article/details/82715778